PHPNUKE TO RAVENNUKE

  Post new topicReply to topicPrintable Version
<< View previous topic View next topic >>
Share: Del.icio.us  Digg  Google  Spurl  Blink  Furl  Y! MyWeb  
#1   PHPNUKE TO RAVENNUKE
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
Hey there,

Ok this may sound extreem but i have been unhappy with the way my forum has been running and think it does not have the latest tools i need so i decided yesterday that im going to go for a full convert from phpnuke to ravennuke becouse they are similare on the backend hoever nukeraven has alot more tools to play with,

I managed to export important tables like users, posts, forums, topics all that stuff, and then overwrote the ravennuke tables and checked the site and ravennuke was fully working with all my users posts and was able to sighn in with my account from phpnuke so that all went well,

All mods worked great attachment nukesentual and otehr stuff this is the catch i thought i would go test the registration of a new member on the ravennuke site and i filled in all the fields with the correct information and clicked submit "but nothing" no error just no responce like the button wasent even submiting the information to the forum can any one shed any light on this issue,

I read on the ravennuke forum a few posts but it led to nothing they blamed the server can this be down to a server issue,

Thanks for reading regards joe,



Back to top Reply with quote
#2   
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
Hi there,

Well after looking around and checking, i kind of managed to work things out my self i relised that the issue must be in the actual form for posting maby a database incompatability so i decided to downgrade the moduals/Your_account/index.php to an earlyer realese and it works perfect now new members are being added to the database,

one other thing tho ravennuke has an advanced interface for admins adding users in the admin section howerver qwhen i try to add a test user it decideds to pop up with an error ERROR: There was a problem updating the database. so looks like i may have to try downgrading this to,

Thanks for reading,



Back to top Reply with quote
#3   re: PHPNUKE TO RAVENNUKE
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
hi,

LMAO i fix one issue and anouther appears well iv been updating 1 of the themes based in nukeraven so i dont lose the attachment function every thing has been going well untill i wanted to add a custome a navagation banner for my header.html file,

However when i upload all the files to the correct places and modify the header html file with the code needed the banner appears but does not function as a navigation banner, i get the feeling the modules or some other file that reads the html is striping the .css files needed,

I will show you how i modified the code and a screen dump of the banner its self, and will give you a link to the banners source,
[ Register or login to view links on this board. ]




Back to top Reply with quote
#4   
Telli
Site Admin
Telli has been a member for over 15 year's 15 Year Member
Occupation: Self Employed
Age: 40
Fav. Sports Team: Detroit Red Wings
Website: www.codezhost.com
Status: Offline
Joined: May 26, 2003
1.46 posts per day
Posts: 8090
Points: 494,335
   
Can you add the css into the theme css? Thats generally the best option. That way your not loading more then one css file.

The problem with the Your Account module is more then likely the the fields arnt matching up with data your inputting. For example Raven Nuke may have some added fields in the nuke_users database table that the file does not have.




_________________
The path of the righteous man is beset on all sides by the inequities of the selfish and the tyranny of evil men. Blessed is he, who in the name of charity and good will, shepherds the weak through the valley of darkness, for he is truly his brother's keeper and the finder of lost children. And I will strike down upon thee with great vengeance and furious anger those who would attempt to poison and destroy my brothers. And you will know my name is the Lord when I lay my vengeance upon thee. Ezekiel 25:17
Back to top Reply with quote
#5   re: PHPNUKE TO RAVENNUKE
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
Well this is a good suggestion telli becouse when i enable main.css for some reason my whole forum distorts and changes font to be honest i kindoff am lost when it comes to merging css files, I would love to get this imagenavigation banner working in my forum,

How would i go around merging there css with my forum css, if you dont mind me asking, sorry to be a pain mate.

Your totaly right about the usr registration fields i downgraded the fields they were saying on ravennuke forum it was something to do with mail function not working,

o well youv been a star mate cheers,



Back to top Reply with quote
#6   
Telli
Site Admin
Telli has been a member for over 15 year's 15 Year Member
Occupation: Self Employed
Age: 40
Fav. Sports Team: Detroit Red Wings
Website: www.codezhost.com
Status: Offline
Joined: May 26, 2003
1.46 posts per day
Posts: 8090
Points: 494,335
   
Thats one issue I am suprised Raven Nuke didn't workout. There should be only one css file for the whole site. The only issue is the Forums css sets a font size and the Nuke theme sets a font size so when you change one of them the other looks a little off. You have to add them all into one css file and then do some editing to suit your needs.




_________________
The path of the righteous man is beset on all sides by the inequities of the selfish and the tyranny of evil men. Blessed is he, who in the name of charity and good will, shepherds the weak through the valley of darkness, for he is truly his brother's keeper and the finder of lost children. And I will strike down upon thee with great vengeance and furious anger those who would attempt to poison and destroy my brothers. And you will know my name is the Lord when I lay my vengeance upon thee. Ezekiel 25:17
Back to top Reply with quote
#7   re: PHPNUKE TO RAVENNUKE
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
Thanks for the fast reply telli,

Ok iv been messing around and found that the css file im looking for is the styles.css and yea i added the imagemenu .css in to it and it works just like when its being refrenced inside the header.html but i dont have to refrence it no more great,

However i tryed a little more and decided to just check if the .css was cuasing the fault or javascript and from the looks of removing the <script> tags from my header.html there is no fault in the forum it just loads with the same effect i dont know now if its the acctual javascript being blocked from running becouse as soon as i add the javascript bk in its fault straight away,

This has cought me out, Could this be sorted or do you think iv hit a dead end with this one,

Heres a screen dump now of the acctual failt when javascript is added to header.html



Back to top Reply with quote
#8   
Telli
Site Admin
Telli has been a member for over 15 year's 15 Year Member
Occupation: Self Employed
Age: 40
Fav. Sports Team: Detroit Red Wings
Website: www.codezhost.com
Status: Offline
Joined: May 26, 2003
1.46 posts per day
Posts: 8090
Points: 494,335
   
There is a javascript error. Is it active on the site now?

I can see one issue here:


      <script type="text/javascript">
         
         window.addEvent(\'domready\', function(){
            var myMenu = new ImageMenu($$(\'#imageMenu a\'),{openWidth:240, border:2, onOpen:function(e,i){alert(e);}});
         });
      </script>


You have to remove those forward slashes.

You might want to consider running it through a validator you have several HTML errors.



_________________
The path of the righteous man is beset on all sides by the inequities of the selfish and the tyranny of evil men. Blessed is he, who in the name of charity and good will, shepherds the weak through the valley of darkness, for he is truly his brother's keeper and the finder of lost children. And I will strike down upon thee with great vengeance and furious anger those who would attempt to poison and destroy my brothers. And you will know my name is the Lord when I lay my vengeance upon thee. Ezekiel 25:17
Back to top Reply with quote
#9   re: PHPNUKE TO RAVENNUKE
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
I see where your comming from telli thats weard phpnuke seems to be adding them its self i just checked,

this is the output index.html of a page i uploaded my self, [ Register or login to view links on this board. ]

type="text/javascript">
         
         window.addEvent('domready', function(){
            var myMenu = new ImageMenu($$('#imageMenu a'),{openWidth:240, border:2, onOpen:function(e,i){alert(e);}});
         });
      


This one is outputing from phpnuke page,

type="text/javascript">
         
         window.addEvent(\'domready\', function(){
            var myMenu = new ImageMenu($$(\'#imageMenu a\'),{openWidth:240, border:2, onOpen:function(e,i){alert(e);}});
         });
      


Well done looks like you found what is exactly making it not work fixing it is the issue can the site be adding in thos slashes telli,


Back to top Reply with quote
#10   re: PHPNUKE TO RAVENNUKE
joeontherun
CZ Newbie
 Codezwiz Site Donator
joeontherun has been a member for over 11 year's 11 Year Member
Status: Offline
Joined: Sep 16, 2006
0.00 posts per day
Posts: 20
Points: 525
   
Hi telli,

After the piece of code you found to be invalid it got me thinking becouse when i looked at other scripts being ran through the forum there were like 6 scripts being listed in the sorce however i did not see any direct javascript code on the forum so i decided to create a .js file and stick that small script in there and link it like the rest and guese what it worked thanks alot your a guenuse,

God knows why i could not run the javascript directly from header.html must be protection but there we go heres the catch its still notifying me of an error in my page even though the banner is fully working any suggestions,

Fantasitic cheers,



Back to top Reply with quote
Display posts from previous:      
Add To: Del.icio.us  Digg  Google  Spurl  Blink  Furl  Y! MyWeb  
<< View previous topic View next topic >>
Post new topicReply to topic

Jump to 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum