Buttons are giving me fits

  Post new topicReply to topicPrintable Version
<< View previous topic View next topic >>
Share: Del.icio.us  Digg  Google  Spurl  Blink  Furl  Y! MyWeb  
#1   Buttons are giving me fits
knarf
CZ Newbie
knarf has been a member for over 16 year's 16 Year Member
Status: Offline
Joined: Mar 18, 2004
0.00 posts per day
Posts: 28
Points: 1,509
   
Same movie as in the other post. Trying to put a "REPLAY" and an "ENTER" button at the end. Got it all done as far as I can tell, but they don't work when I test the move. They seem to act as text (you can highlight, copy and paste) within the movie. On the stage, the REPLAY button does work, it actually starts the movie playing from frame 1. Of course the ENTER button does nothing on the stage because it has a gotoURL action on it. But, both buttons do turn the pointer into a hand when the pointer is hovered over them (stage only, NOT in movie test).

All I did to create these buttons is turn a text field into a symbol with button behavior. Then I set the up, over, down, and hit properties. Next, dragged them from my library onto the stage, enabled "simple buttons", and they don't do what they are supposed to when the movie is tested. They don't even work in a publish preview in HTML format.

Any ideas?



Back to top Reply with quote
#2   re: Buttons are giving me fits
knarf
CZ Newbie
knarf has been a member for over 16 year's 16 Year Member
Status: Offline
Joined: Mar 18, 2004
0.00 posts per day
Posts: 28
Points: 1,509
   
If I make the HIT graphic considerably bigger than the rest of the button, the area around the visible button becomes clickable during the movie test. Why is it doing this? It seems as if the contents of the UP, OVER, and DOWN frames cover up the contents of the HIT frame. All contents of all the frames are graphic symbols.

I give up, I have get some sleep before work. icon_evil.gif



Back to top Reply with quote
#3   re: Buttons are giving me fits
redhot_2oo3
PayPal Donation
CZ Moderator
redhot_2oo3 has been a member for over 16 year's 16 Year Member
uk.gif
Occupation: Codezwiz Elf
Website:
Status: Offline
Joined: Aug 26, 2003
0.10 posts per day
Posts: 633
Points: 25,047
   
When making text into links or button actions, I usually put an invisible rectangle underneath it. This is because the text can be hard to click on.
Try just leaving the text as text (convert to graphic symbol tho) and making a rectangle that just covers it, covert to button, reduce the alpha to zero and give it the button actions you need.




_________________
Back to top Reply with quote
#4   re: Buttons are giving me fits
knarf
CZ Newbie
knarf has been a member for over 16 year's 16 Year Member
Status: Offline
Joined: Mar 18, 2004
0.00 posts per day
Posts: 28
Points: 1,509
   
Ok, I think that's basically what I was trying to do, but I may have been doing it in the wrong order or somthing...I will try your method and see if that helps...thanks.



Back to top Reply with quote
Display posts from previous:      
Add To: Del.icio.us  Digg  Google  Spurl  Blink  Furl  Y! MyWeb  
<< View previous topic View next topic >>
Post new topicReply to topic

Jump to 
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
You cannot attach files in this forum
You cannot download files in this forum